Introduction

General Concepts

There are some key concepts that are helpful for understanding how to interact with VIDA. Individual objects in VIDA can be in various states, including Focused, Visible, Locked, Marked, and Selected. Each of these states carries some special behaviors which are described below. These states also provide a way to refer to specific molecules or sets of molecules. For example, one could apply a coloring scheme or rendering style to all Marked objects, or to the Focused object.

VIDA’s “Scope” determines which objects will be affected by operations within the program, based on their states, and is discussed in the “Scope” section below.

Focused State

The Focused state is a property of a single object in the application; there can be only one Focused object at any given time. Being Focused indicates that that particular object is the current object of interest and is therefore the primary focus of all relevant windows. If the Focused object is not already Visible (see below), it will behave as if it were Visible for as long as it remains Focused.

In addition, when a molecule is the Focused object, its SMILES representation is displayed in the application’s status bar (which can be found at the bottom of the application window). If any of the molecule’s atoms are selected, that selection will be indicated in the SMILES display by the coloring of relevant atoms. Selected atoms are colored using the current selection color (the default is orange) and are also in a bolded font while all of the unselected atoms will be displayed in their usual normal black font.

For large molecules (>100 atoms in this case), no SMILES representation is displayed as it would not fit in the status bar.

Visible State

The Visible state is an indicator of whether or not the associated object is drawn in the 3D display. Multiple objects can be Visible simultaneously. If VIDA is operating in tiled mode (see Tiled Display), each Visible object will be displayed in its own individual pane.

If the 2D display is also shown and VIDA is in tiled mode, Visible molecules will be drawn in the 2D display as well as the 3D display.

Locked State

The Locked state is essentially the same as the Visible state except in the situation where the application is in tiled mode, in which case each Locked object will be displayed in every pane of the 3D display. However, a Locked object can also be simultaneously Visible and/or Focused in which case it will be displayed in its own individual pane as well as every other pane in the 3D display.

Marked State

The Marked state is simply an indicator of user interest in the associated object. The Marked state can be used to help filter data as well as to specify the desired input to application functions. For instance, the Marked state can be used to specify which molecules out of a large list are saved. Finally, when certain operations generate too many results to be displayed at one time, the Marked state can be used to indicate the results of those operations.

Selected State

The Selected state is a special property of the Visible state. Only objects that are Visible, Focused, or Locked can be Selected. Much like the Marked state, the Selected state is an indicator of interest and provides an input set to application functions. Unlike, the Marked state, the Selected state is more transient and is easily cleared. The act of selection is usually performed in either the 3D or 2D display. Selected objects are usually indicated by a change of color (the default is orange) in the 2D display, and by a colored outline in the 3D display. More details on the actual process of selection can be found in the chapters on 3D and 2D displays.

Scope

Scope is a state of VIDA, and indicates which objects the application should operate on. The default application scope is Focused which means that all of the application functions will operate on the Focused object.

_images/scopes.png

Scope Order of Precedence

However, as seen in Figure: Scope Order of Precedence, if there is anything currently Selected, the selected set will take precedence over the current scope i.e. the action will apply only to the selected atoms/objects. Furthermore, in Focused scope, if there is no Selected set and no Focused object, the Focused scope defaults to behaving as if it were the Visible scope.

The Visible scope operates on all objects that are currently Visible, Locked, and/or Focused.

The Marked scope operates on all objects that are currently Marked.

The All scope operates on every object currently loaded in the application. Operating on the All scope can be a very lengthy process, and as such, its progress is displayed in the progress bar in lower right hand corner of the application. Operations performed on the All scope can be halted if desired by clicking on the Stop button immediately to the left of the progress bar.

The current scope is displayed in and can be modified from the main application toolbar as seen in the figure below.

_images/scope_toolbar.png

Scope Toolbar Control

Layout

The layout of the application should be relatively familiar to most users. VIDA provides a menu bar with many standard as well as specific menus, a toolbar for common operations, a central main window, and a number of peripheral windows. An example of the layout can be seen in Figure: Docked Layout.

_images/applayout.png

Docked Layout

The layout including the position and visibility of the main and peripheral windows is saved on exit and will be restored the next time the application is run. The layout of the windows can be changed by clicking on the title bar of the individual window and dragging it to the desired location. A placeholder window will appear when the mouse is over an area where the dragged window can be placed as seen in Figure: Dragging Windows.

_images/layout_change.png

Dragging Windows

Furthermore, multiple windows can be tiled on top of each other into a tab controlled area as can be seen in the bottom window in Figure: Docked Layout. This example shows tabs for “Spreadsheet” and “Scripting Window”.

_images/layout_toolbar.png

Custom Layouts

In addition to manually changing the layout, there are a number of predefined layouts which are accessible via a drop down button on the toolbar as can be seen in Figure: Custom Layouts. The colored icon associated with each option indicates which peripheral windows will be shown and where. Hovering the mouse over any given option for about one second will generate a preview image of the resulting layout. The “Save” option allows for the creation and storage of custom layouts. The “Organize” option enables the reorganization of the ordering of the layouts.

Main Window

The main window is the window that occupies the central area of the application on the screen. At any given time, there can be only one main window; however, there are multiple windows which are capable of being the main window if desired. The choice of main window can be controlled by selecting the desired option from the “Main window” submenu in the top-level Windows menu. In Figure: Docked Layout, the 3D display (see 3D Display) is serving as the main window.

Currently, there are three different main window options: the 3D display, the 2D display, and the spreadsheet. More details about the individual windows can be found in their relevant chapters.

Fullscreen

In addition to the standard layout described above, the main window can optionally be displayed in fullscreen mode, by selecting the “Fullscreen” option in the top-level View menu. Pressing the “Esc” key will exit fullscreen mode (please note that clicking the mouse on the screen may be required before hitting the “Esc” key in order to ensure that the key press is registered).

When in fullscreen mode, the main menu bar and status bar are hidden by default. However, they can be toggled on or off by hitting the “F1” and “F2” keys respectively.

The 3D display normally contains popup toolbars around the edge of the window. These toolbars remain when in fullscreen mode to allow for easy access to display functionality. For more details on these toolbars see 3D Display.

Peripheral Windows

In addition to the main window, there can be multiple peripheral windows docked around the edges of the main window or as separate floating top level windows. Furthermore, multiple windows can be placed on top of each other in a tabbed region.

Currently, multiple peripheral windows (including the potential main windows) are available:

  • 2D Display
  • 2D Preview
  • 3D Viewer
  • Builder
  • List Window
  • Scripting Window
  • Spreadsheet
  • Style Control

The display of peripheral windows is controlled by toggling the desired window options in the Windows menu. Currently visible windows are indicated by the presence of a check mark next to their names. Peripheral can also be hidden by clicking on the ‘X’ in the upper right hand corner of the window. As mentioned above, the layout of the peripheral windows can be controlled by dragging the individual windows to their desired locations (see Figure: Dragging Windows).

Undo / Redo

VIDA provides multi-step undo and redo functionality for almost all operations. Operations can be undone by selecting the “Undo” option in the Edit menu, clicking on the undo button in the top 3D toolbar, or by hitting Ctrl+Z on the keyboard. Any of these actions will undo the last operation performed. This can be done repeatedly or the undo history can be viewed in the “Undo History” option the Edit menu which allows selecting how far back into the undo history to go. Please note that while this menu only displays the 10 most recent operations, the undo history can be much greater, so feel free to revisit the “Undo History” option to go back further.

Operations that were just undone can be redone by selecting the “Redo” option in Edit menu, clicking on the redo button in the top 3D toolbar, or by hitting Ctrl+Y on the keyboard. Any of these will redo the last operation undone. This can be done repeatedly or the redo history can be viewed in the “Redo History” option in the Edit menu which allows selecting how far into the redo history to go. Like the undo history, this menu only displays the 10 most recent undone operations, but the redo history may be much greater and can be revisited to go further.

Mouse Map

User interaction in the 3D display is primarily performed using the mouse. The following table details the available functions as well as the mouse actions required to perform those functions.

Function Mouse Action
Zoom Scroll wheel
Zoom Move mouse with Middle button
Zoom Move mouse with Left + Right buttons
Rotate Move mouse with Left button
Rotate around Z axis Move mouse with Left button + Alt key
Translate in XY plane Move mouse with Left button + Shift key
Translate in Z plane Scroll wheel with Alt key
Select Click Left button
Select rectangle Move mouse with Right button
Select add Click Left button with Ctrl or Shift key
Select grow Double click Left button
Select add grow Double click Left button Ctrl or Shift key
Select rectangle and add Move mouse with Right button and Ctrl or Shift key
Change clipping plane Scroll wheel with Ctrl + Shift key
Change far clipping plane Scroll wheel with Alt + Ctrl key
Change near clipping plane Scroll wheel with Alt + Shift key
Text scale Scroll wheel with Ctrl key
Menu Click Right button
Adjust contour level Scroll wheel with Shift key
Show labels Move with Ctrl key

Special Builder Mouse Actions

When a molecule is in Editing mode, the Rotate and Translate in XY plane actions above can be applied exclusively to the molecule being edited by holding down the Ctrl key (Command key on a Macintosh) while rotating or translating.

User Directory

VIDA stores user specific information in a user writable local directory on the computer running the application. Contained in this directory are the user’s application settings (VIDA.ini), preferences (preferences.oeb), journal file (journal.py), and a cached copy of the license file (oe_license.txt).

The location of the user directory is specific to the operating system, the details of which are listed below:

Linux / Unix

~USERNAME/.OpenEye/VIDA/4.3

Mac OS X

/Users/USERNAME/Library/OpenEye/VIDA/4.3

Microsoft Windows Vista / Windows 7 / Windows 8

C:\Users\USERNAME\AppData\Local\OpenEye\VIDA\4.3

The user directory can be accessed from within VIDA by clicking on the “Open User Directory” option within the Help menu.

Help

Help with VIDA can be found under the Help menu in the main menubar as well on the OpenEye website: http://www.eyesopen.com. The Help menu provides an About option, access to documentation, licensing utilities, access to Examples, access to the User Directory, as well as the ability to file a bug report.

About

The About box provides extensive details about the running version of VIDA as well as the system on which that VIDA is running. It also provides licensing information and direct access to the license file in use.