Release Notes

VIDA v4.3.0 (August 2014)

New Features

  • “Drag and Drop” is now supported for rearranging items in the List Window.
  • Advanced depiction options, including atom property maps from the Grapheme TK, substructure highlighting, and 2D structure alignment, are available for depiction in the 2D window and spreadsheet.
  • Improved surface rendering using the new “atom splitting” feature from the Spicoli TK.
  • Atom-based selection of surfaces.
  • Atom and surface selection is now indicated using bright outlines instead of atom coloring.
  • A new “Select” menu provides a wide range of ways to select atoms. The menu also allows creation and manipulation of named sets of atoms.
  • A surface hydrophobicity coloring scheme based on atomic XLogP contributions was added.
  • A new surface “curvature” coloring scheme was added that combines the previous “concavity” and “curvature” schemes.
  • An additional VIDA extension for coloring molecules by SD data is included.
  • An example “Cluster Browsing” script, for viewing clustered molecule data, is included.
  • Many enhancements were made to the Extensions Manager dialog, to allow better handling of extension subscriptions. Other extension improvements include the ability to specify the order in which extensions are loaded, and the ability to use the VIDA_EXTENSIONS_URL environment variable to specify multiple auto-subscriptions.
  • Molecular surfaces can now be created over sets of selected atoms, and can be regenerated via the Style Control.
  • The VIDA spreadsheet can now include generic data stored on molecules and conformers.
  • The List Window now allows clicking on column headers to show/hide, mark, and lock all items in the list.
  • The builder now issues a warning (and opportunity to cancel) if a protein molecule has been put into Edit mode.
  • Extension authoring was made easier by allowing local filenames in .pyx and .pyxs files.

Major Bug Fixes

  • A crash from undoing conformer deletion has been fixed.
  • A number of stability issues and strange window behavior under OS X 10.8+ have been resolved.
  • A crash while creating C-alpha traces for some proteins was fixed.
  • Several operations in the sketcher could create radicals unexpectedly. This has been corrected.

Minor Bug Fixes

  • Fixed a warning message when opening .cdx files.
  • A problem with state files not preserving child object visibilities was corrected.
  • SMILES (.smi) files now contain stereochemical information by default.
  • Installation of some extensions caused reading of large files to slow down significantly.
  • The save dialog was very slow to initialize for large files.
  • New lists created (e.g., from “Marked” molecules) now become the current active list.
  • Switching to stereo during a telemodeling session would lose synchronization between the connected sessions.
  • B-Factor labels can now be shown on any atoms, not just C-alpha atoms.
  • Files opened via the command line now appear in the “Recents” list.
  • Fixed an issue with extension updates requiring an extra VIDA restart to take effect.
  • A problem with exiting fullscreen mode was fixed.
  • A crash on exit when using certain extensions on Linux machines was fixed.
  • Grids rendered from CCP4 files now use the statistics embedded in the file, rather than statistics generated within VIDA.

Platform Support

  • Support for Ubuntu 14 was added.
  • Support for RedHat v7 was added.
  • Support for Mac OS X 10.8 and 10.9 was added.
  • Mac OS X 10.6 is no longer supported.
  • RedHat v4 is no longer supported.
  • Windows XP is no longer supported.

Other

Vivant is being retired, and no longer ships with VIDA. Existing versions of Vivant will continue to function and remain compatible with VIDA‘s current state files.

VIDA v4.2.0 (September 2012)

New Features

  • A “telemodeling” feature has been introduced (as an included VIDA extension), and allows interactive sharing of VIDA sessions over a network.
  • 3D graphics shading calculations have been redone, to provide much nicer looking rendering of 3D objects.
  • Solid-rendered 3D objects now include edge outlines to improve clarity.
  • VIDA‘s spreadsheet has been updated with several new features:
    • Depictions now use the new OEDepict TK, and can be displayed in color.
    • Atom selection is reflected in the spreadsheets.
    • Structures from SMILES strings can now be displayed in spreadsheet cells. Just put the string “(smiles)” anywhere in the column name.
    • URL’s in the spreadsheet are now treated as active hyperlinks.
    • Row heights can be adjusted all at once, to interactively scale (and hide) molecular depictions.
    • The VIDA Name column has been removed.
    • New columns can be added via a “+” button in the spreadsheet headers
  • Spreadsheets can now be exported directly to PDF files.
  • Filenames of files opened within VIDA now show in the title bar of VIDA‘s main window.
  • The behavior of the “Recents” menu has been changed, so that it now displays both recently opened and recently saved files, including VIDA state (.oes) files. In addition, a “Recent Directories” menu has been added.
  • A “protein sequence” coloring scheme has been added which colors protein molecules using a gradient from N-terminus (blue) to C-terminus (red).
  • The Extension Manager has been rewritten to simplify the user interface.
  • VIDA can now automatically subscribe to sets of VIDA Extensions pointed to by the environment variable, VIDA_EXTENSIONS_URL.
  • Several rarely-used icons have been removed from VIDA‘s main window, and the “Style Toolbar” at the top of the 3D window is now empty by default.
  • An example docking extension is now provided, to allow docking of molecules against a pre-prepared receptor for customers with an OEDocking TK license.
  • New commands for disabling and clearing VIDA‘s “Undo” stack have been added to the scripting API. These can be used to prevent repeated operations from building up large amounts of “undo” memory unnecessarily.
  • VIDA can now read MTZ crystallographic reflection files from several common refinement programs and generate regular and difference maps from them.
  • A new preference setting allows molecules without 3D coordinates to be displayed in the 3D window.
  • Monitors (for distances, torsions, etc.) can now be deleted from within the “Measure” option in the Mouse Toolbar.
  • VIDA now incorporates the released versions of OpenEye toolkits, including the newer OEDocking TK, OEDepict TK, and Grapheme TK.
  • The Preferences dialog behavior has been modified to allow updating of preferences without dismissing the dialog.
  • The installer for Windows now allows association of user-selectable file types with VIDA.
  • Load times have been significantly improved for files containing large numbers of molecules.

Major Bug Fixes

  • Under certain conditions, working with a protein with alternate conformations could cause corruption of state files. This has been corrected.
  • A problem causing failure of molecule check-ins after deleting and re-adding hydrogens has been fixed.
  • A severe graphics slowdown on Windows machines with Intel HD Graphics video has been addressed by new OpenGL rendering methods.
  • A bug which caused atom names to sometimes be lost when merging molecules has been fixed.
  • Stereochemistry is now preserved when pasting structures from ChemDraw or reading .cdx files.
  • A graphics bug which made all 3D labels show up in black on certain video cards has been corrected.

Minor Bug Fixes

  • Molecules created by typing a name in the builder would be named with a SMILES string instead of the type-in name, unless a valid Lexichem TK license was found.
  • MoleculeColorByScope() and related functions have been fixed to work properly with molecule keys in the Scratch Scope.
  • Molecule surfaces are now automatically updated when the molecule is edited.
  • On machines with desktops spanning multiple monitors, VIDA could sometimes place the main window and Preferences dialog offscreen.
  • The VIDA icon now shows correctly when the application is pinned to the taskbar in Windows.
  • Disabled inner contours from FRED receptor files are no longer displayed.

Platform support

Support for Ubuntu 12 (x64) and Mac OS X 10.7 has been added.

VIDA v4.1.1 (November 2011)

New Features

  • Ability to save and restore preferences in extensions. Many of the example extensions were updated to make use of this new capability, and now preserve settings between VIDA sessions.
  • Capability to customize molecule lookup and property calculation functions in the builder.
  • Adjustable jitter and a new coloring method for grids rendered using the “cloud” style.
  • Ability to disable OpenGL hardware rendering via Preferences, to circumvent issues with certain video drivers (most notably, the Intel HD Graphics drivers for Windows).

Major Bug Fixes

  • Fixed a crash that sometimes occurred when performing distance selection on proteins.
  • Addressed an issue which could cause bond visibilities to become corrupted.
  • Fixed an issue which could cause long delays entering build mode in sessions with large molecules.
  • Multi-conformer molecules with child molecules were not being displayed properly in the List Window. This has been fixed.
  • Resolved a crash that could occur during torsion measurements on Linux machines.
  • Fixed a problem with excessive memory consumption when surfaces were scribed and cropped multiple times.
  • Corrected a severe slowdown caused by an interaction of some extensions with a molecule selection dialog.
  • Fixed an issue which made check-ins of multiconformer molecules very slow.

Minor Bug Fixes

  • Changed the way FRED View displays binding site residues in the absence of a reference ligand.
  • Lasso selection in the 2D Sketcher was leaving hydrogens in the 3D window unselected. This has been corrected.
  • An issue preventing VIDA from reading files with capitalized or mixed-case file extensions was fixed.
  • A problem which caused torsion measurements on Windows platforms to be incorrectly rendered was fixed.
  • Fixed a bug which prevented users from being able to set surface coloring defaults.
  • Made performance improvements to some of the VIDA extensions.

VIDA v4.1.0 (August 2011)

New Features

  • Simultaneous 2D and 3D editing of small molecules.
  • Ability to rotate and translate molecules independently in the builder.
  • Simplified authoring of extensions, and inclusion of a number of new example extension scripts.
  • Ability to add annotations to existing objects, and have those annotations appear in the List Window.
  • Adjustment of torsion angles within rings to change ring puckers and interconvert axial and equatorial substitutions.
  • Option to use the MMFF94s force field when building molecules.
  • Improved set of fragment templates in the sketcher

Major Bug Fixes

  • Fixed a crash when saving state files after loading a large number of proteins.
  • Fixed a crash when editing cells in a spreadsheet.
  • Centering on selected atoms would sometimes require a change in visibility before taking effect. This has been fixed.
  • Fixed a bug which caused rows to sometimes disappear when cells in a spreadsheet were edited.
  • Spreadsheet depictions are now being updated as molecules are edited.
  • An issue which caused the view to occasionally jump unexpectedly during molecule rotations was fixed.
  • Fixed a problem which sometimes caused crashes while creating measurements in the “All” scope.
  • Changing colors/styles of grids now operates on the proper scope, rather than on all visible grids.
  • Addressed issues with the builder and sketcher which sometimes caused fragments to be joined incorrectly.
  • Fixed a bug which sometimes caused right-click menus to become inoperative.

Minor Bug Fixes

  • Hotkeys for Marked/Locked/Visible now work on selected rows in the spreadsheet, not just the active molecule.
  • Fixed a bug where changes to the spreadsheet cell formats weren’t being propagated immediately to the spreadsheet.
  • Fixed a bug to have VIDA remember the hidden/visible state of depictions in a spreadsheet from one session to another.
  • Fixed an issue with the spreadsheet so that users can’t edit non-editable cells, such as computed values (e.g., molecular weight, number of rotors) and user-defined python expressions.
  • Fixed a sizing problem with the 2D Sketcher window, which had caused some tools in its toolbar to be hidden.
  • When a spreadsheet is created from a list, it is now made the current spreadsheet.
  • Fixed an issue which would cause blank entries to sometimes appear in the List Window.
  • Fixed a rendering problem which caused circles to be displayed incorrectly.
  • Corrected an issue in which text would be incorrectly wrapped within labels.
  • Display of symmetry-related molecules now updates automatically as the view is translated.
  • Surface created in the FRED View are now added to the List Window and can be deleted individually.
  • Grid contours are now contoured by default at the original resolution of the grid file.
  • Contours of a grid can now be temporarily shown, similarly to conformers, by clicking on their names in the List Window.
  • All child objects of grids now show in the List Window. Previously only the contours would show.
  • Corrected an issue which sometimes caused incorrect hydrogen geometries during building.
  • Addressed several issues affecting performance and behavior of spreadsheets.
  • Fixed an issue that could sometimes cause incorrect stereochemistries to appear in 2D depictions.
  • Fixed a bug which caused stereochemistry to be omitted from molecules when copying to the clipboard.
  • Corrected strange lasso behavior in the sketcher.

Platform support

Support for Ubuntu 10 (x64) and RedHat Enterprise v6 (x64) was added. RedHat Enterprise v3 is no longer supported.

VIDA v4.0.3 (June 2010)

Improvements

  • Fixed extension loading to enforce rules more consistently & clearly. Added a dialog to notify a user when an extension fails to load at startup.
  • Menu items which throw exceptions other than a cancel runtime exception now will display a dialog rather than failing quietly.
  • Bookmark widget buttons are a touch larger to make them easier to click.
  • Augmented menu API to add functions MenuGetAllItems, MenuItemIsAMenu, MenuDisplayNameGet and MenuDisplayNameSet. It should now be possible to determine complete menu structure at runtime.
  • Sketching a new molecule is much improved. It now features a simple click and click-and-drag interface.
  • The invert stereo button in the 2D sketcher & 3D editor is now the default. It also has a slightly improved icon.

Major Bug Fixes

  • Hitting the down arrow in the spreadsheet could result in the current row being reset to the first row, making it impossible to scroll with the arrow keys.
  • After a lot of editing & deletion, the list window could end up with a corrupted display.
  • Some children objects were not properly preserving visibility in state files. Affected types included monitors, and surfaces and grids which were toggled in the style control.
  • Files containing Unicode characters previously might fail to load. They should now load properly.
  • Improperly constructed extensions could cause problems for the extension manager. The previously might look loaded even though they were not. VIDA now handles erroneous extensions correctly.
  • The right click “Minimize” option in builder mode attempted to call a non-existent function
  • Screenshots in .jpg format resulted in empty files on Microsoft Windows
  • In some cases, the save dialog would only allow a single item to be clicked.

Minor Bug Fixes

  • Stereochemistry in the 2D depictions was not displayed in the spreadsheet or the 2D preview window.
  • On some platforms, the graphics widget that controls slabbing and depthcue in the style control can dramatically slow down VIDA, especially for spreadsheet operations. When it is collapsed, this slow down does not occur. As a temporary work around, the collapsed state of the style control (including the graphics widget) is now remembered between sessions.
  • Documented the AppVersion, AppVersionMajor, AppVersionMinor and AppVersionBugFix commands.

VIDA v4.0.2

  • VIDA 4.0.2 was an internal release

VIDA v4.0.1

  • VIDA 4.0.1 was an internal release

VIDA v4.0.0 (August 2009)

New Features

  • Added a 1D/2D molecule input dialog which supports SMILES, names, and interactive building.

  • Added a 3D editing mode which enables significant modification of the current molecule including in-vacuo minimization with MMFF94.

  • Added support for DNA/RNA ribbon style visualization

  • Added support for displaying and controlling alternate residue conformations (turn on ALL flavor when reading PDB files to enable this) as well as a number of coloring schemes associated with alternate residues

  • 2D depiction in 3D display is now selectable

  • Add object-type specific tool buttons to the bottom display which provide context sensitive operations such as coloring and style options.

  • Added the ability to import all of OpenEye’s Python toolkits for use within VIDA, provided that the user has a license for those toolkits.

  • Added the ability to transfer molecules, grids, and surfaces between the main application and the bundled OpenEye Python toolkits.

  • Added support for PythonQt scripting within VIDA.

  • Added support for PyQt scripting with VIDA (separate license required from Riverbank computing).

  • Added interactive protein depictions in the spreadsheet.

  • Added many new atom properties to the atom spreadsheet.

  • Added a residue spreadsheet which is capable of controlling alternate residue conformations.

  • Added the ability to load molecules directly from the PDB ( “File > Open Special > From PDB” )

  • Added the following command line arguments:

    -e - Runs the associated file through the Python interpreter and populates the sys.argv variable with the remaining command line arguments

    -eonview - Loads the associated files and processes them using the built in EON view

    -fredview - Loads the associated files and processes them using the built in FRED view

    -rocsview - Loads the associated files and processes them using the built in ROCS view

    -import - Loads the associated files and immediately launches the spreadsheet import dialog

  • PICTO application now ships with VIDA. PICTO requires a valid VIDA license.

Improvements

  • Significantly increased the speed of searches performed within VIDA.
  • Significantly improved and expanded the scripting examples that come with the distribution.
  • Significantly optimized the loading of OEB molecule files which contain attached grids.
  • When displaying Marked molecules, now only the carbon atoms (as opposed to all) are colored using the Marked color unless the non-carbon atoms are specifically Marked themselves.
  • Optimized the AtomDataGet function when working with multi-conformer molecules.
  • Vastly improved the display and usability of the embedded 3D toolbars

Major Bug Fixes

  • Fixed rendering problems associated with having multiple overlapping transparent surfaces displayed simultaneously.
  • Fixed the handling of triple-quoted strings in the VIDA interpreter.
  • Fixed a bug which was preventing scripts from being aborted while running.
  • Fixed a problem where SD data was being lost on read if one or more conformers in a multiconformer molecule did not have the same SD data fields as the rest.

Minor Bug Fixes

  • Fixed a number of erroneous tooltips.
  • Fixed a few spelling errors in prompts and widgets.
  • Fixed the behavior of the drop-down selections in the constraints and extra molecule buttons in the FRED View controller.
  • Fixed the hybridization, isotope, and symmetry atom labels.
  • Fixed a bug where the ColorSetScoped function did not color selected atoms if SelectedScope was explicitly specified as opposed to BestScope.
  • Fixed the MoleculeMergeScoped function to ensure that residue information is not lost when two molecules are merged together.
  • Fixed the standard deviation function in the spreadsheet.
  • The “Create Spreadsheet” option for list entries in the list windows now works as expected.
  • Fixed the coordinates returned in the AtomData class by the AtomDataGet function when working with multi-conformer molecules.
  • Silenced a large number of annoying and unnecessary warnings that would appear in the scripting window

VIDA v3.0.0

New Features

  • Added dynamic help system
  • Added new 2D depiction color schemes: black on white, white on black, color on white and color on black
  • Added new molecule coloring schemes: amino, chain, group, cpk, cpknew, shapely, bfactor, formal charge, and partial charge
  • Added new surface hydrophobicity scales: charifson, eisenberg, kyte-dolittle, and white-octanol
  • Added support for reading attached grids and surfaces in OEB files
  • Added support for reading Spicoli geometric annotations
  • Added support for reading FRED receptor files
  • Added new hydrogen style: polar hydrogens only
  • Added multiple new atom and bond label types (including one for OEChem generic data)
  • Added new 3D display mouse maps for Coot and PyMol

Improvements

  • Anti-aliasing of text and 2D depictions
  • Much better control over placement of dock windows
  • Dock windows can be stacked on top of each other in tabs
  • Single toolbar at the top of the application
  • Additional popup toolbars placed around edge of main window
  • Enabled grid contour transparency
  • Hydrogen style is now a molecule specific property instead of a global property
  • C-Alpha trace display is now a molecule specific property instead of a global property
  • Ribbon display is now a molecule specific property instead of a global property
  • Many miscellaneous 3D rendering improvements and accelerations
  • Many miscellaneous user interface improvements

Major Bug Fixes

  • Upgraded to OEChem 1.5 which fixed a number of bugs

Minor Bug Fixes

  • Fixed a problem on some graphics cards where only aromatic rings would be drawn when a molecule was in stick mode

VIDA v2.1.2

New Features

  • Added “Copy Image” function under the Edit menu which takes a screenshot of the current main window and places it on the clipboard
  • Added “Map Index” atom label corresponding to the value returned by the OEChem function OEAtomBase::GetMapIdx().

Improvements

  • Updated menu system to be compliant with standard UI design practices (such as ‘...’ usage when menu option launches a dialog)
  • Updated menu system on Mac OS X to follow common Mac paradigms (e.g. “Open Recents” and “Preferences...” options)
  • Reorganized File menu for more logical placement of options
  • Collapsed “New > List >” submenu structure to a single “New List >” submenu which appears after the Open, Save block
  • Added “New Molecules >” submenu which contains a “From Split” submenu which provides the “Split Molecules” functionality from the old Edit menu.
  • Renamed “Clear All” option to “Clear” and moved up in the menu above Save block
  • Removed “Abort Script” option as it was redundant (Stop button next to progress bar performs this function) and also could generally not be accessed while a script was running
  • Reorganized Edit menu for more logical placement of options as well as to provide some commonly performed operations in a single place
  • Moved “Split Molecules” functionality to File menu
  • Added new “Select” submenu which contains the following options: All Visible, Query, Invert, and None
  • Added new “Mark” submenu which contains the following options: All, Query, None
  • Added new “Hide” submenu which contains the following options: All, Selected, Marked, Not-Selected, Not-Marked, and None
  • Removed the following options as they were redundant given the above additions: Hide All, Clear Marked
  • Alphabetized list of available windows in the Window menu
  • Batch shell window no longer appears when running on Windows
  • Redesigned process manager window for easier use
  • Significantly improved the quality of POV-ray exports and reduced the output file size
  • Improved the rendering of electrostatic grids

Major Bug Fixes

  • Upgraded to OEChem 1.4.1 which fixed a number of bugs associated with handling bad input files
  • Fixed a cross-platform compatibility issue in state files

Minor Bug Fixes

  • Fixed “MolecularEnergy()” calculation method in spreadsheet to correctly report energies on multi-conformer molecules
  • Fixed “SpreadsheetFilter()” command such that it operates on the specified spreadsheet instead of the current spreadsheet
  • Ensured that all current environment variables are properly passed to processes started from the process manager
  • Fixed the icon on the hydrogen display button to accurately reflect what will occur when the button is pressed
  • Fixed a Mac OS X bug where double-clicking on a molecule file started VIDA but did not actually load the file that was clicked on

VIDA v2.1.1

Improvements

  • Filled out Sybyl mouse map in more detail
  • Added “fixed size text” option for labels (see Preferences) such that the label font size remains fixed independent of zooming in the scene, however the font size can be adjusted using the “Text Scale” slider in the Style Bar window
  • Added the ability to specify the font for labels when using “nice fonts” for labels (see Preferences)
  • Added a “custom” option to the atom and bond label dialogs to allow for easier specification of custom labels without having to use scripting commands
  • Improved the drawing of labels such that they always appear in front of the object they are labeling
  • Improved the ability to see the selected state of partially selected residues in the sequence view
  • Added file dialog filter option to allow reading of ASCII formatted grids (.agd)
  • Added support for native builds on Intel Macs

Major Bug Fixes

  • Fixed a problem with reading spreadsheet information in state files generated by VIDA 2.0.x which caused extra tabs to appear in the spreadsheet
  • Fixed a problem with writing spreadsheet information correctly in VIDA 2.1
  • Fixed a crash when reading a badly formatted state file (potentially generated by the bug fixed above)
  • Fixed a crash when attempting to import a non-standard whitespace delimited spreadsheet (whitespace is not a supported spreadsheet delimiter)
  • Fixed a crash on certain video cards when attempting to display “fixed size text” labels
  • Fixed a crash caused by dragging state files onto the application icon in order to open them
  • Fixed an application hang when reading badly formatted XPLOR maps
  • Fixed an application hang when reading a badly formatted OEB file
  • Fixed a memory leak generated when running a large number of scripting commands

Minor Bug Fixes

  • Fixed a problem where extra atom labels could appear on molecules when saved to state
  • Fixed a problem where CTRL-mouse over atom displays were not seen when using non-VIDA mouse maps
  • Fixed a bug in the “Text Scale” slider where its position did not always reflect the current scale being used
  • Fixed a bug where OE_DIR and OE_LICENSE environment variables were not being properly exported to the Process Manager on Mac OS X such that spawned applications could not find a valid oe_license.txt file
  • Fixed a bug where exporting a CSV file on Microsoft Windows attached an extra return character causing a blank line to appear between each row when read into Microsoft Excel
  • Fixed a few cases where the display of depictions in the spreadsheet was not obeying the set preferences
  • Fixed a bug where extra calls to undo cleared the redo stack
  • Turned off the writing of empty data fields when writing molecules to SD or OEB formats. This can be turned back on if truly desired from the Preferences

VIDA v2.1.0

New Features

  • Added interactive text annotation of molecules
  • Added the ability to start, monitor, terminate, and load results from external processes
  • Added a protein sequence viewer as part of the 2D depiction widget
  • Added the oechemlite Python module, enabling significantly greater scripting functionality within VIDA
  • Added the ability to create arbitrary sphere monitors via the scripting API (see Python API for documentation of the new method CreateSphereMonitor(...))
  • Added support for fullscreen display
  • Added new emph{cloud} visualization style for grids
  • Added support for copy and paste of molecules from ISIS/Draw
  • Added support for use of the Maestro mouse map in the 3D display
  • Added support for saving screenshots in JPG format in addition to PNG

Improvements

  • Cleaned up the appearance of the right-click popup menus
  • Added a “Style” option to the right-click popup menus, when appropriate to the context, which mirrors the main “Style” menu
  • Added significantly greater detail to info labels created when holding down the “ctrl” (or “alt” on Mac) key when moving the mouse in the 3D or 2D views
  • Added two default filtered spreadsheets to the application: “Molecules” and “Proteins”
  • Filled out the scripting API for greater control of the GUI - in particular for menus and toolbar
  • Greatly improved the electrostatic coloring scheme for protein surfaces
  • Added the ability to change the font used by the application

Major Bug Fixes

  • Fixed a crash when trying to generate electrostatic contours on extremely small molecules (e.g. water)

Minor Bug Fixes

  • Fixed a number of preferences that were not being properly saved or obeyed by the application
  • Fixed the undo stack such the initial setup of the 3D display cannot be undone by accident
  • Fixed the display of angle monitor measurements from radians to degrees
  • Fixed the display of the text scale widget such that it is not hidden on low resolution monitors
  • Made sure that when saving images and state files, a proper file extension is added to the filename, even if one was not specified

VIDA v2.0.2

Improvements

  • Added “Style” menu to the main menubar which replicates the functionality of the style control (useful in low-resolution settings)
  • Added “Center” and “Color” options to the popup dialogs
  • Enabled display of named network drives in the file dialog
  • Enabled use of native file dialogs instead of custom VIDA file dialog as a preference.
  • Improved 3D visualization support for lower-end graphics cards
  • Increased default line width in 3D scene for better visibility
  • Enabled transparent display of grids (via the “Style” menu)
  • Added simple spreadsheet import preview dialog to help select the proper column delimiter (tab vs. comma)
  • Added SpreadsheetCurrentSet() function which allows specification of current spreadsheet via scripting interface
  • Improved the SD file reader for better handling of badly formatted SD files
  • Improved the handling of situations in which the atom indices specified in input files differ from the order in which they are specified
  • Improved start-up time as license detection mechanisms have been significantly improved

Major Bug Fixes

  • Fixed right-click on empty 2D depiction crash
  • Fixed spreadsheet import failure on linux
  • Fixed mainwindow snapshots such that file dialog does not obscure the image to be captured
  • Fixed license detection routines such VIDA will properly detect installed licenses and not cause start-up problems if the license file is moved
  • Fixed all other reported crashes not otherwise listed

Minor Bug Fixes

  • Fixed a bug in the detection of a user’s home directory in networked environments on Microsoft Windows
  • Fixed a bug in “measurement” mode where the first atom or bond picked was not being drawn as selected
  • Fixed a bug where spreadsheet filtering performed via the scripting interface would not behave as expected if the specified spreadsheet was not the same as the current spreadsheet
  • Fixed an uncommon situation in which the locked and visible controls in the list window do not work as expected
  • Fixed the handling of certain “escape characters” in filenames specified on the commandline, files dragged onto the VIDA icon, and the “startup.py” file such that they no longer prevent the opening of those files